Jump to content


Photo

Sankyo Sound-501 Projector


  • Please log in to reply
No replies to this topic

#1 Richard MacKenzie

Richard MacKenzie

    New

  • Basic Members
  • Pip
  • 1 posts
  • Student

Posted 28 July 2010 - 07:33 AM

Dear all,

I'm new to the forum but I've been into all forms of 8mm for years. Recently, I obtained an almost cosmetically perfect Sankyo Super 8 Sound-501 projector. It came complete with all the original packaging and accessories, even the original box, all in excellent condition. The projector also came with a 2-pin plug instead of the usual. I got hold of a standard kettle lead and it all works perfectly in 18fps. However, when switched to 24fps there is no action whatsoever. All lights and the speaker remain on but that's it. I don't think its a belt problem because in 18fps mode it works instantly, not needing to warm-up. Its currently set to 220v and as I said, looks like its never been used.

Any help would be much appreciated,
Many thanks,
Richard.
  • 0


Rig Wheels Passport

CineLab

Technodolly

Wooden Camera

Abel Cine

Ritter Battery

Tai Audio

New Pro Video - New and Used Equipment

Visual Products

FJS International, LLC

Metropolis Post

Media Blackout - Custom Cables and AKS

Willys Widgets

Gamma Ray Digital Inc

Paralinx LLC

rebotnix Technologies

CineTape

The Slider

Glidecam

Broadcast Solutions Inc

Aerial Filmworks

Wooden Camera

Broadcast Solutions Inc

Tai Audio

CineLab

New Pro Video - New and Used Equipment

FJS International, LLC

The Slider

Metropolis Post

Media Blackout - Custom Cables and AKS

Ritter Battery

Abel Cine

Visual Products

Aerial Filmworks

CineTape

Willys Widgets

Paralinx LLC

Rig Wheels Passport

Technodolly

Glidecam

Gamma Ray Digital Inc

rebotnix Technologies