Jump to content


Photo

Using an SR2 after one year of non-use


  • Please log in to reply
1 reply to this topic

#1 Frank DiBugnara

Frank DiBugnara
  • Basic Members
  • PipPipPip
  • 168 posts

Posted 03 March 2006 - 11:08 PM

Does anyone see any potential problems arising from shooting with an SR2 (body and mags) that has not been run in about a year? Scratch tests came out fine. I assume all the internal lubrication will "re-disperse" itself as the moving parts move again. Any other signs of malfunction to be aware of?

Thanks.

Frank Di Bugnara
  • 0

#2 Tim Carroll

Tim Carroll
  • Sustaining Members
  • 2168 posts
  • Other
  • Chicago, Illinois

Posted 04 March 2006 - 12:50 AM

If you are using the on-board batteries, are they holding a charge. I run my SR once a month, ten minutes on each mag and battery, and charge the batteries about every other month. That keeps it in good shape between jobs.

-Tim
  • 0


Aerial Filmworks

Willys Widgets

Abel Cine

Ritter Battery

Media Blackout - Custom Cables and AKS

New Pro Video - New and Used Equipment

CineTape

Technodolly

Paralinx LLC

CineLab

Broadcast Solutions Inc

Gamma Ray Digital Inc

Visual Products

Glidecam

Wooden Camera

The Slider

rebotnix Technologies

FJS International, LLC

Metropolis Post

Rig Wheels Passport

Tai Audio

CineTape

FJS International, LLC

The Slider

Glidecam

Metropolis Post

Media Blackout - Custom Cables and AKS

Abel Cine

Wooden Camera

rebotnix Technologies

CineLab

Ritter Battery

Willys Widgets

Aerial Filmworks

Technodolly

Gamma Ray Digital Inc

Paralinx LLC

New Pro Video - New and Used Equipment

Broadcast Solutions Inc

Tai Audio

Rig Wheels Passport

Visual Products