Jump to content


Photo

Beaulieu 5008 S Multispeed.. Different Versions?


  • Please log in to reply
6 replies to this topic

#1 Turbe

Turbe
  • Basic Members
  • PipPip
  • 24 posts
  • Other

Posted 31 May 2006 - 09:05 PM

Hello,

I just received my Beaulieu 5008 S Multispeed Camera.. I did not receive a manual but I have a pdf version. In the Beaulieu Case side pouch, there is a piece of paper with the following on it:

___________________________________________________________

Do NOT disconnect lens if main swith is ON!!

This Beaulieu 5008 S Camera is equipped with 800mA NiMh ,,green'' accu whis has NO
memory effect!

If this camera is one of the latest models with viewfinder LED:

RED LED:
,,TEST" - red light = low currant
aperture ,,MANUAL" - red light = wrong manual aperture setting
aperture (Manual or Automatic) - strong red lght = f1.4
Sound control - right VU level = slight flickering red light

GREEN LED:
Sound control - flickering with sound from microphone or connected tape

____________________________________________________________________

And, yes, spelling is as above... :)

My pdf manual states a viewfinder needle with a notch on the right side (while looking into the viewfinder). There is not a needle (or needle movement?) and more importantly, no notch at all. There is the LED on the top of the viewfinder.

Does anyone know about a 5008 S Multispeed model that uses a LED for the exposure control system instead of a meter (in the viewfinder)?

If a model exists that doesn't use a needle, I assume from the note included that I don't want a RED light for proper exposure (in manual mode), but what about automatic exposure?

Thanks in advance..

Shawn
  • 0

#2 A.Oliver

A.Oliver
  • Basic Members
  • PipPipPipPip
  • 348 posts
  • Other
  • Croydon UK

Posted 01 June 2006 - 03:53 AM

Hi, dont worry, my 5008s is the same as yours, exposure is indicated via the red led. Its been a long time since i owned a 5008s ( two speed) so cannot remember if the earlier version did have an exp needle. My recently purchased 5008ms dates from 1978, gives great images and is the most underated beaulieu.
Andy
  • 0

#3 Turbe

Turbe
  • Basic Members
  • PipPip
  • 24 posts
  • Other

Posted 01 June 2006 - 09:37 AM

Hi, dont worry, my 5008s is the same as yours, exposure is indicated via the red led. Its been a long time since i owned a 5008s ( two speed) so cannot remember if the earlier version did have an exp needle. My recently purchased 5008ms dates from 1978, gives great images and is the most underated beaulieu.
Andy


Hi,

Is yours a 5008 S Multispeed? (I believe the Multispeed, not MS model is the latest of the 5008 series??)...The other 5008 S Multispeeds I have seen had needles, perhaps they were older versions...

In Auto exposure mode, what does the RED LED indicate (f1.4? over/under exposure?)
  • 0

#4 A.Oliver

A.Oliver
  • Basic Members
  • PipPipPipPip
  • 348 posts
  • Other
  • Croydon UK

Posted 01 June 2006 - 01:03 PM

Hi, mine is a 5008-s multispeed ( 8, 18, 24, 45fps ), camera body is black. Under exp in auto mode red led illuminates, led does not illuminate if over exposed. Thus appears led only indicates under exp in auto mode only.
  • 0

#5 Turbe

Turbe
  • Basic Members
  • PipPip
  • 24 posts
  • Other

Posted 01 June 2006 - 06:56 PM

Hi, mine is a 5008-s multispeed ( 8, 18, 24, 45fps ), camera body is black. Under exp in auto mode red led illuminates, led does not illuminate if over exposed. Thus appears led only indicates under exp in auto mode only.


Thanks for the info...

I think I like they way this version works better than having a needle..

Shawn
  • 0

#6 paulhanssen

paulhanssen
  • Guests

Posted 07 June 2006 - 07:56 AM

Thanks for the info...

I think I like they way this version works better than having a needle..

Shawn



I liked the needle better, since with the needle you can see if you are close to the right exposure, or not. You can not estimate over or underexposure with the led, at least not through the viewfinder.

paul
  • 0

#7 ken wood

ken wood
  • Basic Members
  • PipPip
  • 37 posts
  • Other

Posted 26 June 2006 - 04:59 PM

I have 3008 multispeed. I am new to Super 8 and this camera.
What I have found on to 3008 is when exposure is wrong hi/low the red LED shows in top of window.
  • 0


CineTape

FJS International, LLC

Gamma Ray Digital Inc

Tai Audio

Rig Wheels Passport

Visual Products

The Slider

rebotnix Technologies

Broadcast Solutions Inc

Technodolly

Ritter Battery

Glidecam

Metropolis Post

Paralinx LLC

CineLab

Aerial Filmworks

Wooden Camera

Opal

Willys Widgets

Abel Cine

Media Blackout - Custom Cables and AKS

CineTape

Rig Wheels Passport

Metropolis Post

FJS International, LLC

Broadcast Solutions Inc

Aerial Filmworks

Media Blackout - Custom Cables and AKS

Visual Products

Abel Cine

Ritter Battery

Technodolly

rebotnix Technologies

CineLab

Willys Widgets

Tai Audio

Glidecam

Gamma Ray Digital Inc

The Slider

Wooden Camera

Paralinx LLC

Opal