Jump to content


Photo

Bell & Howell Filmosound TQI


  • Please log in to reply
3 replies to this topic

#1 JB Guillot

JB Guillot
  • Basic Members
  • PipPip
  • 78 posts
  • Other
  • France

Posted 29 March 2007 - 07:26 AM

Hi 16mm users !

I just inherited a 16mm projector from Bell & Howell written Filmosound TQI (or TQ1 I don't know) on the side.

I payed a bit with it managed to see some of the films that were given with it...seems in good shape just a bit dusty.

I just have a problem with the sound which has no (or not much) high frequencies...so sound is awfull with just low frequencies.

I would like to fix it but don't have a user manual or whatever could help me wo if you have any tricks that could help me.

Just some more info, sound is optical in may case and I just learnt a bit about it and might try some manipulations given on another forum (French one).

Anyway if you have any experience with this kind of projector or if you have copies of the instruction manual (or know where I can find it)...I would really appreciate your help !

Cheers.

Gybe
  • 0

#2 JB Guillot

JB Guillot
  • Basic Members
  • PipPip
  • 78 posts
  • Other
  • France

Posted 29 March 2007 - 10:54 AM

I finally found some ways to correct the sound problem I had. It's not so bad now...

Still I have some question about the connectors of this projector ; here's a pic :
Posted Image
The connector on the right is for the speakers, I have the cable and everything...but what about the other 2 ? Do you know something about the little signs that appear near the plugs ?

Thanks for your help !
  • 0

#3 Charles MacDonald

Charles MacDonald
  • Sustaining Members
  • 1157 posts
  • Other
  • Stittsville Ontario Canada

Posted 29 March 2007 - 08:34 PM

Do you know something about the little signs that appear near the plugs ?

Thanks for your help !

I think the middle one is for Phono, and that would probaly leave the left one for a microphone. (free PA amplifier with every Projector)
  • 0

#4 JB Guillot

JB Guillot
  • Basic Members
  • PipPip
  • 78 posts
  • Other
  • France

Posted 30 March 2007 - 01:46 AM

I think the middle one is for Phono, and that would probaly leave the left one for a microphone. (free PA amplifier with every Projector)

You may be right...I tested yesterday night : the left one (with the yellow tape) is for the microphone and middle one probably for phono IN, as no sound was coming out of it.

Thanks for your help ! And if some of you have the instruction manual or find it some day it would be great to share it ;)
  • 0


Gamma Ray Digital Inc

The Slider

Technodolly

Willys Widgets

Visual Products

Wooden Camera

Media Blackout - Custom Cables and AKS

CineLab

Glidecam

FJS International, LLC

Ritter Battery

Rig Wheels Passport

Metropolis Post

Aerial Filmworks

Abel Cine

Tai Audio

CineTape

Opal

Broadcast Solutions Inc

rebotnix Technologies

Paralinx LLC

Metropolis Post

Tai Audio

Aerial Filmworks

Glidecam

Technodolly

rebotnix Technologies

Gamma Ray Digital Inc

CineLab

CineTape

Media Blackout - Custom Cables and AKS

Ritter Battery

Paralinx LLC

Rig Wheels Passport

Wooden Camera

Willys Widgets

Abel Cine

Visual Products

Broadcast Solutions Inc

Opal

The Slider

FJS International, LLC