Jump to content


Photo

The "iris blades" will not move when I adjust the aperature ring.


  • Please log in to reply
5 replies to this topic

#1 Hans Engstrom

Hans Engstrom
  • Basic Members
  • PipPipPip
  • 195 posts
  • 1st Assistant Camera
  • Sweden

Posted 16 June 2008 - 07:21 AM

Bought this lens from ebay http://cgi.ebay.de/w...em=330239650631 . It arrived today but when I move the aperature ring the iris blades inside the lens will not move, they are stuck almost wide open.
Seller says that his AC didn´t notice any problems with it the last time they used it.

Since I got it cheap I figured its better to get it fixed then to try to return it.
Anyone know whats wrong and how much it will cost to fix it and perhaps where I should have the work done? I´m located in Sweden so I´d prefer to have the work on it done inside EU (less hassle with customs).
  • 0

#2 Saul Rodgar

Saul Rodgar
  • Basic Members
  • PipPipPipPip
  • 1682 posts
  • Cinematographer

Posted 16 June 2008 - 10:46 AM

Bought this lens from ebay http://cgi.ebay.de/w...em=330239650631 . It arrived today but when I move the aperature ring the iris blades inside the lens will not move, they are stuck almost wide open.
Seller says that his AC didn´t notice any problems with it the last time they used it.

Since I got it cheap I figured its better to get it fixed then to try to return it.
Anyone know whats wrong and how much it will cost to fix it and perhaps where I should have the work done? I´m located in Sweden so I´d prefer to have the work on it done inside EU (less hassle with customs).


I would send it directly to Zeiss in Germany. That can be expensive, you'll get the best service though. They may not work on it since it has the Optex conversion. There is Les Bosher in the UK, he is cheaper and very good. Maybe he could fix that, you can always ask.
  • 0

#3 Olex Kalynychenko

Olex Kalynychenko
  • Basic Members
  • PipPipPipPip
  • 868 posts
  • Cinematographer
  • Dnepropetrovsk, Ukraine

Posted 16 June 2008 - 10:55 AM

Bought this lens from ebay http://cgi.ebay.de/w...em=330239650631 . It arrived today but when I move the aperature ring the iris blades inside the lens will not move, they are stuck almost wide open.
Seller says that his AC didn´t notice any problems with it the last time they used it.

Since I got it cheap I figured its better to get it fixed then to try to return it.
Anyone know whats wrong and how much it will cost to fix it and perhaps where I should have the work done? I´m located in Sweden so I´d prefer to have the work on it done inside EU (less hassle with customs).


I can suppose,
The mechnaism of aperture control broken and can be problem with control pin.
The control pin can be broken or arcuated or lost.
But, can be more complex problme, the problme with iris, the broken blades or lost blades.
You can see of blades inside lens ?
The ring of aperture control turn easy ?
  • 0

#4 Paul Bruening

Paul Bruening

    (deceased)

  • Sustaining Members
  • 2858 posts
  • Producer
  • Oxford, Mississippi

Posted 16 June 2008 - 11:32 AM

PM Stephen Williams. He's 'da man over there, for questions from folks here.
  • 0

#5 Hans Engstrom

Hans Engstrom
  • Basic Members
  • PipPipPip
  • 195 posts
  • 1st Assistant Camera
  • Sweden

Posted 16 June 2008 - 12:21 PM

I can suppose,
The mechnaism of aperture control broken and can be problem with control pin.
The control pin can be broken or arcuated or lost.
But, can be more complex problme, the problme with iris, the broken blades or lost blades.
You can see of blades inside lens ?
The ring of aperture control turn easy ?


I can see all the blades and they are all in the "same" position creating an opening that you usually see when the lens is at T2.4. The aperture ring turns easy and before I looked thru the lens I didn´t suspect any problems with it. When I move the aperture ring to T2.4 and turn it back and forth while looking thru the lens I can see minor movement on a dust particle that sits on one of the blades.
  • 0

#6 Hans Engstrom

Hans Engstrom
  • Basic Members
  • PipPipPip
  • 195 posts
  • 1st Assistant Camera
  • Sweden

Posted 16 June 2008 - 12:24 PM

Thanks for all input folks. I sent a mail to Les the moment I found out about the problem but I haven´t received an answer yet. Will PM Stephen Williams.
  • 0


Wooden Camera

Tai Audio

Metropolis Post

Media Blackout - Custom Cables and AKS

Broadcast Solutions Inc

Rig Wheels Passport

CineTape

The Slider

CineLab

Abel Cine

Visual Products

Aerial Filmworks

Glidecam

Ritter Battery

rebotnix Technologies

Technodolly

Gamma Ray Digital Inc

Opal

Paralinx LLC

Willys Widgets

FJS International, LLC

Metropolis Post

Aerial Filmworks

CineLab

Ritter Battery

rebotnix Technologies

Technodolly

Media Blackout - Custom Cables and AKS

Gamma Ray Digital Inc

Wooden Camera

FJS International, LLC

Tai Audio

The Slider

CineTape

Opal

Willys Widgets

Visual Products

Paralinx LLC

Glidecam

Broadcast Solutions Inc

Abel Cine

Rig Wheels Passport