Jump to content


Photo

Nizo light meter issue


  • Please log in to reply
No replies to this topic

#1 jon lawrence

jon lawrence
  • Basic Members
  • PipPip
  • 82 posts
  • Student

Posted 30 December 2008 - 03:26 PM

I just brought a nizo 801macro and have noticed then when I look through the viewfinder and pull the trigger there is no movement from the light meter when set on auto exposure. There is still no movement when I switch over to manual exposure and move the nob. In fact I can't see a needle move at all except for when I test the batteries for the camera (not the meter batteries).
Has this happened to anyone before? I figure it must be the meter batteries but thought that I should be able to control it manualy. Anyone know what's up?

Any help would be much appreciated.
-Jon
  • 0


Broadcast Solutions Inc

Technodolly

FJS International, LLC

Metropolis Post

rebotnix Technologies

Glidecam

Paralinx LLC

Tai Audio

The Slider

Media Blackout - Custom Cables and AKS

Abel Cine

CineLab

Ritter Battery

CineTape

Wooden Camera

Gamma Ray Digital Inc

Aerial Filmworks

New Pro Video - New and Used Equipment

Visual Products

Willys Widgets

Rig Wheels Passport

Visual Products

CineTape

FJS International, LLC

Ritter Battery

Technodolly

New Pro Video - New and Used Equipment

Aerial Filmworks

CineLab

Metropolis Post

Paralinx LLC

Tai Audio

The Slider

Media Blackout - Custom Cables and AKS

Wooden Camera

Gamma Ray Digital Inc

Willys Widgets

Broadcast Solutions Inc

Abel Cine

rebotnix Technologies

Glidecam

Rig Wheels Passport