Jump to content


Photo

DV Codec lifting all blacks when exporting


  • Please log in to reply
11 replies to this topic

#1 Daniel Smith

Daniel Smith
  • Basic Members
  • PipPipPipPip
  • 791 posts
  • Other

Posted 24 February 2009 - 07:43 PM

Hi.

I encountered a problem when exporting a video some time ago. For some reason, the standard DV codec on my computer in Avid seems to lift all the blacks when exporting.

I ran several tests, when exporting uncompressed the blacks were fine, when exporting with Avid DV codec, the blacks were fine. I thought maybe it was the way quicktime player was playing back the standard DV footage, so I exported some video using the standard DV codec, re-imported it and then exported back out uncompressed and the DV coded had permanently lifted the blacks into a nasty grey.

Has anyone else had this problem before?

I also tried exporting and importing using both RGB and 601/709 colours levels and neither made any difference. Aswell as exporting in 16x9 square pixel and anamorphic DV.

tnx.
Dan.

Edited by Daniel Ashley-Smith, 24 February 2009 - 07:44 PM.

  • 0

#2 Adrian Sierkowski

Adrian Sierkowski
  • Sustaining Members
  • 7118 posts
  • Cinematographer
  • Los Angeles, Ca

Posted 24 February 2009 - 08:01 PM

Check on some scopes, but perhaps AVID has black at 0 IRE when in reality for SD broadcast they should be 7.5 IRE, hence the raise on export.
  • 0

#3 Michael Collier

Michael Collier
  • Basic Members
  • PipPipPipPip
  • 1262 posts
  • Gaffer
  • Los Angeles, CA

Posted 25 February 2009 - 03:47 PM

I think the black level is a project setting in avid. If you have footage whose blacks are 7.5 already, but the project is set to 0 and the export 7.5 IRE black is on, then your blacks would be 15 IRE. Check the blacks in your scope and see if that's the case. If so look at your project settings and capture settings.
  • 0

#4 Phil Rhodes

Phil Rhodes
  • Sustaining Members
  • 11944 posts
  • Other

Posted 25 February 2009 - 05:28 PM

Careful, folks - Daniel is in the UK, and probably working in PAL, which doesn't use setup.

Is there any Quicktime involved anywhere? Quicktime is notorious for trying to be too clever and making everything look milky.

P
  • 0

#5 Daniel Smith

Daniel Smith
  • Basic Members
  • PipPipPipPip
  • 791 posts
  • Other

Posted 25 February 2009 - 07:44 PM

The footage was standard DVCAM from a DSR and I've tried using stills images aswell. Both yeild the same results.

I set the black low level to 0 instead of 16 and weirdly it makes no difference, even though 16 is the equivalent of 7.5 IRE. If I set it 32 as an online guide tells me it just gets worse.


It's being exported out to a quicktime file, using the 'DV - PAL' codec. I've tried all kinds of combinations, RGB, 601/709 etc.

What's weird though is that when I export using the Avid DV codec it comes out fine.

For some reason I can't export out to an AVI via the standard DV codec through Avid.


I personally think there's something wrong with my codec. As quicktimes playing every other codec fine, and when I reimported the footage and exported as uncompressed the standard DV codec had permanently washed out the footage. Whereas I can do this with the Avid DV codec or purely uncompressed and it comes out fine.

Another reason I think it's the codec is that the same thing occurs when exporting from After effects.

Edited by Daniel Ashley-Smith, 25 February 2009 - 07:48 PM.

  • 0

#6 Daniel Smith

Daniel Smith
  • Basic Members
  • PipPipPipPip
  • 791 posts
  • Other

Posted 25 February 2009 - 07:57 PM

Ok ignore the bit about the blacks coming out the same in after effects, as they seem ok now, but it's coming out insanely soft. I've made sure the aspect ratios etc. have been constant so there's no up-rezzing or stretching.
  • 0

#7 Phil Rhodes

Phil Rhodes
  • Sustaining Members
  • 11944 posts
  • Other

Posted 25 February 2009 - 08:59 PM

First of all, where Quicktime is involved, all bets regarding black level are off. God knows what it does, I don't have the relevant background, but it does something - possibly in a misguided attempt to compensate for the perceived difference in gamma between Mac and PC displays.

As regards the softness - if you're in AE, ensure you've actually set the comp up to render full res, either by setting it as the resolution option in the comp viewer or by overriding that setting in the render queue. The problem is that AE will by default render at whatever resolution the comp is set to, then scale that render up to the output size. If it didn't do this, the DV codec would reject the undersized frame, alerting you to the fact that something is wrong. You aren't an AE user until you've sat through a slow (but somehow suspiciously fast) render only to discover your pride and joy has been output at Youtube resolution. This will just look like a half- or third-res image, depending how you had the comp viewer set up.

Also check that your DV codec is set to full resolution decode, since many of them offer a faster, half-res decode which looks like complete junk. This will look like a very badly JPEG'd low-res image that's been scaled up. This would be in the codecs manager in Device Manager for directshow or video for windows codecs, or presumably somewhere in Quicktime for that.

P
  • 0

#8 Daniel Smith

Daniel Smith
  • Basic Members
  • PipPipPipPip
  • 791 posts
  • Other

Posted 10 March 2009 - 12:58 PM

I think the problem may be when it is when it's stretched to 16x9, as when I exported an uncompressed version of my footage in 4x3(16x9) the blacks came out grey, however when I exported uncompressed 16x9 square pixel it came out fine.

However the problem persists any way I do it with DV- PAL.


I've had a look into altering settings but can't seem to find anything for DV - PAL. Tried changing the clip low level to 0 and it comes out the same as low clip level 16.

The thing that stops me thinking it's the way quicktime is playing it is that I re-import it into Avid and it has been permanently lifted from the export.



For now I'm just outputting everything as uncompressed. It's the only safe option. Hopefully getting a new pc soon anyway so, if it's a problem specific to this pc then hopefully it will go.




Never knew the post process could be so tedious lol

Edited by Daniel Ashley-Smith, 10 March 2009 - 01:00 PM.

  • 0

#9 Josh Bass

Josh Bass
  • Basic Members
  • PipPipPipPip
  • 552 posts
  • Other

Posted 10 March 2009 - 02:54 PM

If it's any consolation, I sometimes have these issues (Or maybe always and the project sometimes doesn't make them apparent). In camera, in NLE, blacks are deep, rich, gorgeous. Output to DVD. . .milky. Sometimes green too. Good times. This happened when I was using Vegas, haven't really done enough with FCP to have an issue yet.
  • 0

#10 Phil Rhodes

Phil Rhodes
  • Sustaining Members
  • 11944 posts
  • Other

Posted 10 March 2009 - 03:02 PM

Greenish blacks is a common indicator of a duff MPEG-2 encoder.

P
  • 0

#11 Josh Bass

Josh Bass
  • Basic Members
  • PipPipPipPip
  • 552 posts
  • Other

Posted 10 March 2009 - 09:43 PM

Greenish blacks is a common indicator of a duff MPEG-2 encoder.

P



As in native to FCP/compressor/Vegas? I suppose the unduff solution is like $2000 or something?
  • 0

#12 Phil Connolly

Phil Connolly
  • Basic Members
  • PipPipPipPip
  • 377 posts
  • Director
  • London

Posted 11 March 2009 - 05:19 AM

I recently had similar black issue's with Avid Express - when exporting the project as a targa sequence. Graphics that should have been at true black, were sat up - very odd. This was on a HD 25p project so not sure why avid should be messing about with black levels. So the problem goes beyond the DV codec - that said it could have been my editor being stupid - but I'm pretty sure the Targa export settings were correct.

I was able to fix this using further colour correction in an online suite - but its an annoying extra step.

Once TV shows start being delivered as files rather then on tapes, I think we are going to have lost of export problems in this area.
  • 0


Aerial Filmworks

Visual Products

Broadcast Solutions Inc

CineLab

rebotnix Technologies

FJS International, LLC

Metropolis Post

Glidecam

The Slider

Opal

Technodolly

Wooden Camera

Tai Audio

Rig Wheels Passport

Gamma Ray Digital Inc

Media Blackout - Custom Cables and AKS

Abel Cine

Ritter Battery

Willys Widgets

CineTape

Paralinx LLC

The Slider

Wooden Camera

Media Blackout - Custom Cables and AKS

CineLab

Aerial Filmworks

FJS International, LLC

Ritter Battery

Tai Audio

Gamma Ray Digital Inc

Abel Cine

Metropolis Post

CineTape

Glidecam

rebotnix Technologies

Paralinx LLC

Rig Wheels Passport

Opal

Technodolly

Visual Products

Willys Widgets

Broadcast Solutions Inc