Jump to content


Photo

Sankyo Sound-501 Projector


  • Please log in to reply
No replies to this topic

#1 Richard MacKenzie

Richard MacKenzie

    New

  • Basic Members
  • Pip
  • 1 posts
  • Student

Posted 28 July 2010 - 07:33 AM

Dear all,

I'm new to the forum but I've been into all forms of 8mm for years. Recently, I obtained an almost cosmetically perfect Sankyo Super 8 Sound-501 projector. It came complete with all the original packaging and accessories, even the original box, all in excellent condition. The projector also came with a 2-pin plug instead of the usual. I got hold of a standard kettle lead and it all works perfectly in 18fps. However, when switched to 24fps there is no action whatsoever. All lights and the speaker remain on but that's it. I don't think its a belt problem because in 18fps mode it works instantly, not needing to warm-up. Its currently set to 220v and as I said, looks like its never been used.

Any help would be much appreciated,
Many thanks,
Richard.
  • 0


Willys Widgets

The Slider

CineLab

Wooden Camera

Metropolis Post

Glidecam

Opal

rebotnix Technologies

Ritter Battery

Tai Audio

FJS International, LLC

Broadcast Solutions Inc

Aerial Filmworks

Technodolly

Visual Products

Rig Wheels Passport

Paralinx LLC

Media Blackout - Custom Cables and AKS

CineTape

Gamma Ray Digital Inc

Abel Cine

Glidecam

Paralinx LLC

CineLab

Tai Audio

Technodolly

The Slider

Willys Widgets

Aerial Filmworks

Wooden Camera

Gamma Ray Digital Inc

Opal

rebotnix Technologies

Media Blackout - Custom Cables and AKS

Broadcast Solutions Inc

Rig Wheels Passport

Ritter Battery

Abel Cine

CineTape

Visual Products

FJS International, LLC

Metropolis Post