Jump to content


Photo

Yashica Super 40 Battery Issues


  • Please log in to reply
No replies to this topic

#1 Ed Bricker

Ed Bricker

    New

  • Basic Members
  • Pip
  • 1 posts
  • Other

Posted 06 August 2010 - 06:50 PM

Hi all,

First time (hopefully not last) time poster.

I have a Yashica Super-40 that I purchased a few years ago and use to film once in awhile. My friends and I are hosting a gathering early tomorrow and I was hoping to film bits and pieces of it... however much to my dismay over the past few days the camera has been acting up. In the morning the camera works fine, and then when i come home from work I cant get anything out of it, and the battery meter reads dead even though I just replaced the main batteries (4 AA's) and the light meter battery (625A... 1.5V not 1.35).

I've no idea whats causing the problem and I can't find a camera shop open tomorrow at any time.

I recently did clean the main battery holder because the AA's that had been in there were leaking, and there was some green copper buildup on a few of the contacts... could this be the problem?

Any help is greatly appreciated.

-Ed
  • 0


rebotnix Technologies

Paralinx LLC

Gamma Ray Digital Inc

The Slider

CineTape

Rig Wheels Passport

Broadcast Solutions Inc

Aerial Filmworks

CineLab

Media Blackout - Custom Cables and AKS

Metropolis Post

Ritter Battery

Tai Audio

Wooden Camera

Willys Widgets

Technodolly

Abel Cine

Glidecam

New Pro Video - New and Used Equipment

FJS International, LLC

Visual Products

Paralinx LLC

New Pro Video - New and Used Equipment

Broadcast Solutions Inc

CineLab

Visual Products

Wooden Camera

FJS International, LLC

Metropolis Post

Rig Wheels Passport

Technodolly

Willys Widgets

rebotnix Technologies

Aerial Filmworks

Gamma Ray Digital Inc

Abel Cine

Glidecam

Ritter Battery

The Slider

Tai Audio

Media Blackout - Custom Cables and AKS

CineTape