Jump to content


Photo

Eumig P8 Phonomatic


  • Please log in to reply
1 reply to this topic

#1 Gareth White

Gareth White

    New

  • Basic Members
  • Pip
  • 1 posts
  • Other

Posted 26 December 2010 - 10:07 AM

Merry Christmas All!

I was given a great gift yesterday of a Eumig 8mm projector with some Chaplin reels............... A dream come true!!

I have just been going through each stage to get the projector running, as per the manual, however when I turn it on there is nothing that happens. No projector light or movement in the rollers. It was tested before it was given to me and it worked fine.

Any ideas what it could be? Fused plug is my first thought? I've been looking all around the net but can't see anyone else with the same problem.

Cheers

Gareth
  • 0

#2 Tim Halloran

Tim Halloran
  • Basic Members
  • PipPip
  • 76 posts
  • Other

Posted 26 December 2010 - 02:22 PM

Try asking here:

http://8mmforum.film.../ultimatebb.cgi

or here:

http://www.mrelmo.co...ormat/index.php

They're more about projectors at those forums, with some seriously knowledgeable folks.

Tim
  • 0


Broadcast Solutions Inc

CineTape

Willys Widgets

Abel Cine

Visual Products

The Slider

Rig Wheels Passport

Aerial Filmworks

Glidecam

Gamma Ray Digital Inc

Paralinx LLC

Ritter Battery

Tai Audio

Opal

FJS International, LLC

Technodolly

Metropolis Post

rebotnix Technologies

CineLab

Media Blackout - Custom Cables and AKS

Wooden Camera

Glidecam

Gamma Ray Digital Inc

Tai Audio

Abel Cine

rebotnix Technologies

Paralinx LLC

The Slider

Visual Products

Rig Wheels Passport

Aerial Filmworks

Metropolis Post

Media Blackout - Custom Cables and AKS

Ritter Battery

Broadcast Solutions Inc

Opal

FJS International, LLC

Technodolly

Willys Widgets

Wooden Camera

CineLab

CineTape