Jump to content


Photo

Nizo S800 lightmeter faulty


  • Please log in to reply
No replies to this topic

#1 Rafael Rivera

Rafael Rivera
  • Basic Members
  • PipPipPip
  • 121 posts
  • Director
  • San Jose, CA

Posted 04 January 2011 - 11:54 PM

I have a Nizo S800 with a temperamental light meter. In auto the meter does not work at all. When doing the meter test, sometimes the needle moves (to f8) sometimes it doesn't move at all. When moving the dial to manual, most of the time the needle will move, but sometimes it won't. The needle always move when doing a main battery test, and if I press the meter black button while doing the main battery test the needle retracts back to the right of f1.8.

I did open up the camera but there was nothing obvious that I could fix, i.e., no objects obstructing lightmeter, etc. And it wasn't obvious either where I could probe with my voltmeter. Any ideas and suggestions as to how to repair the meter are very much appreciated.

I've put in:
- 2 new Wein cells (checked them with voltmeter, both are good)
- new AA batteries. Camera runs fine at all speeds (after following AJ's method to correct the sticky trigger)

For those that would like to open up their S800 but never have I've posted pics here, along with an electrical wiring diagram:


  • 0


Opal

rebotnix Technologies

Broadcast Solutions Inc

CineLab

The Slider

Abel Cine

Tai Audio

Glidecam

Paralinx LLC

Technodolly

Gamma Ray Digital Inc

Willys Widgets

Media Blackout - Custom Cables and AKS

Aerial Filmworks

Ritter Battery

FJS International, LLC

Rig Wheels Passport

Visual Products

Wooden Camera

Metropolis Post

CineTape

Metropolis Post

Ritter Battery

Visual Products

Rig Wheels Passport

Paralinx LLC

Aerial Filmworks

Gamma Ray Digital Inc

Media Blackout - Custom Cables and AKS

rebotnix Technologies

The Slider

FJS International, LLC

Willys Widgets

Broadcast Solutions Inc

Tai Audio

Glidecam

CineLab

Abel Cine

Wooden Camera

Opal

CineTape

Technodolly