Jump to content


Photo

Seeking Help

help pixel Canon 7D correction

  • Please log in to reply
1 reply to this topic

#1 Desiree Weinhofer

Desiree Weinhofer

    New

  • Basic Members
  • Pip
  • 1 posts
  • Student
  • Seattle, WA

Posted 04 January 2013 - 02:38 PM

Hey guys!
I'm 17 years old and started out as an amateur cinematographer about four years ago. I've been doing a few amateur shortfilms and other stuff so far, but never totally on my own. Last fall I got the ultimate opportunity to join a production/filmgroup as their new technical manager and cinematographer. The group consisted of four boys, who'd produced two feature-lenght films before and they took a pretty big risk with me, a girl who'd never worked this professional and with that much responsibility.

Anyways, we shoot the movie last week and I used a Canon EOS 7D. While going trough the material we noticed a white spot near the center of the image. Examining the spot closer, I realized it must be a pixel error on one of the lenses I used. It consists of four pixels (white and three gray tones) and to my misfortune it's clearly visible on most of the footage.
Now, I'm familar with all Adobe programs and Cinema 4D and my question would be:

Has anyone got some advice how I could cover, erase or fade the spot easily?

I'd be so happy about any help. It would really be lifesaving!
Bye for now and thanks in advance!
Desirée
  • 0

#2 Gregory Gesch

Gregory Gesch
  • Basic Members
  • PipPip
  • 12 posts
  • Producer

Posted 04 January 2013 - 07:40 PM

Hi Desiree. A couple of things to try:

In Adobe After Effects draw a tiny, tight mask* around your 4 pixels and set the mask to Inverted (you will now have a 'hole' in your footage where the problem pixels were). Put another copy of your footage on the layer underneath and offset it's X position 2 pixels (or Y position, or both if neccessary - it will depend on the shot). The hole will now be filled with the neighbouring pixels.
If that doesn't work, or works on only some shots, add an adjustment layer above the footage it doesn't work on. Delete the mask on your footage layer and make a slightly larger mask (say 8 x 8 pixels) on the adjustment layer. Add Effects/Box Blur to the adjustment layer and set its Radius to (say) 4. The size of the mask and the radius setting might need playing with.


*When making the mask on your footage place a white solid underneath - when you create the mask it will make it easier to see that you only have the four pixels selected. If you see any fading edges move the corners of the mask until the fading stops and the edges are clean. Then delete the white solid and replace it with the copy of the footage.

Does that work for you?
  • 0



Also tagged with one or more of these keywords: help, pixel, Canon 7D, correction

The Slider

Rig Wheels Passport

Metropolis Post

Wooden Camera

Media Blackout - Custom Cables and AKS

Gamma Ray Digital Inc

CineLab

New Pro Video - New and Used Equipment

Paralinx LLC

Visual Products

CineTape

Broadcast Solutions Inc

Technodolly

FJS International, LLC

rebotnix Technologies

Glidecam

Abel Cine

Ritter Battery

Aerial Filmworks

Tai Audio

Willys Widgets

Media Blackout - Custom Cables and AKS

Tai Audio

Visual Products

Willys Widgets

Paralinx LLC

Ritter Battery

The Slider

Wooden Camera

CineTape

Aerial Filmworks

Abel Cine

New Pro Video - New and Used Equipment

rebotnix Technologies

Glidecam

Technodolly

CineLab

FJS International, LLC

Broadcast Solutions Inc

Metropolis Post

Rig Wheels Passport

Gamma Ray Digital Inc