Jump to content


Photo

Minolta Super8 Battery-Connection Issue

Minolta Super8 battery autopak 8 k11

  • Please log in to reply
1 reply to this topic

#1 Allegra Hangen

Allegra Hangen

    New

  • Basic Members
  • Pip
  • 1 posts
  • Cinematographer
  • Mexico City

Posted 16 June 2015 - 01:08 PM

Hey everyone,

 

I bought a Minolta Autopak 8 K11 super 8 camera a few months ago in Mexico City. When I first shot a roll of color, everything was fine. But after a while the camera would randomly not shoot, the mechanical zoom wouldn't work, and the battery checker on the back couldn't recognize the batteries. But then the next time I picked it up, it would work fine!

 

I assume the connection from the batteries in the handle to the body of the camera is faulty somehow, but I wanted to ask here if anyone has had an issue like this with a Minolta.

 

I hope there is just dust between the connecting points but I'm also not sure what the best solution is for cleaning connections like that.

 

 

 

Anyone have any advice? 

Thanks a bunch.

 

Allegra


  • 0

#2 JD Hartman

JD Hartman
  • Basic Members
  • PipPipPipPip
  • 1808 posts
  • Gaffer
  • Edison, N.J. U.S.A.

Posted 16 June 2015 - 04:51 PM

This: http://www.super8data.com/database/cameras_list/cameras_minolta/minolta_autopak8_k11.htm I'd search Youtube for someone shooting with one.  Maybe they've done some cleaning or repair to the camera and could guide you.


  • 0



Gamma Ray Digital Inc

Rig Wheels Passport

CineLab

Metropolis Post

Ritter Battery

Paralinx LLC

Abel Cine

New Pro Video - New and Used Equipment

Serious Gear

Visual Products

Wooden Camera

Media Blackout - Custom Cables and AKS

Tai Audio

Broadcast Solutions Inc

Glidecam

Serious Gear

Visual Products

Ritter Battery

Media Blackout - Custom Cables and AKS

Gamma Ray Digital Inc

Broadcast Solutions Inc

Wooden Camera

New Pro Video - New and Used Equipment

Metropolis Post

Rig Wheels Passport

CineLab

Abel Cine

Glidecam

Paralinx LLC

Tai Audio