Jump to content


Photo

Help with Nizo S56 - No power


  • Please log in to reply
1 reply to this topic

#1 Christopher Lee

Christopher Lee
  • Basic Members
  • PipPip
  • 14 posts
  • Student
  • Cypress

Posted 04 December 2015 - 10:49 PM

I bought a Nizo S56 a little while back and unfortunately it came broken.  I cleaned the battery compartments for both the meter and motor very well with rubbing alcohol multiple times.  Yet it still didn't operate besides the power zoom.  Any ideas on what could be wrong? Also, the entire side plate (not the side with the controls) is very loose and can be slightly opened when pulled to the side. How do i close the side plate back up? 


  • 0

#2 Mike Brooks

Mike Brooks

    New

  • Basic Members
  • Pip
  • 3 posts
  • Other
  • Dallas

Posted 30 December 2015 - 09:32 PM

Let me know if you find out, I have the exact same power problem.  For awhile it seemed to click off a single frame, but now...nothing.  I was wondering at first if some sort of setting was off/on, but I've run through everything I could think of


  • 0


Metropolis Post

Wooden Camera

New Pro Video - New and Used Equipment

Abel Cine

Paralinx LLC

Serious Gear

Broadcast Solutions Inc

Gamma Ray Digital Inc

CineLab

Glidecam

Visual Products

Tai Audio

Rig Wheels Passport

Media Blackout - Custom Cables and AKS

Ritter Battery

Tai Audio

Metropolis Post

Glidecam

New Pro Video - New and Used Equipment

Paralinx LLC

Wooden Camera

Ritter Battery

Rig Wheels Passport

Media Blackout - Custom Cables and AKS

Broadcast Solutions Inc

Abel Cine

CineLab

Visual Products

Serious Gear

Gamma Ray Digital Inc