Jump to content


Photo

Devry 16mm Projector


  • Please log in to reply
No replies to this topic

#1 Guilherme Panisson

Guilherme Panisson
  • Basic Members
  • PipPip
  • 11 posts
  • Student

Posted 10 August 2016 - 07:41 AM

Hi,

 

Recently I bought this little projector - see photo bellow. I'm having trouble threading the film through it. My trial and error has only helped to damage the film.

As this was made in Chicago, I'm using a power adapter reducing its voltage to 110v, since in my region the current is 220v. I'm saying because the bulb was gone after 1 or 2 minutes of use. I think it was due the long travel. Maybe it has shaken its springs too much. There is also what seems a glow of sparks coming out of the holes of the engine.

Any help would be apprecciated. tks

 

s-l1600.jpg


  • 0


Glidecam

Metropolis Post

Ritter Battery

Rig Wheels Passport

rebotnix Technologies

Tai Audio

Media Blackout - Custom Cables and AKS

FJS International, LLC

CineTape

Technodolly

Opal

Willys Widgets

Broadcast Solutions Inc

CineLab

Abel Cine

Visual Products

The Slider

Paralinx LLC

Wooden Camera

Gamma Ray Digital Inc

Aerial Filmworks

Metropolis Post

Opal

Willys Widgets

Broadcast Solutions Inc

Visual Products

Gamma Ray Digital Inc

FJS International, LLC

Glidecam

Abel Cine

CineLab

Technodolly

Paralinx LLC

Ritter Battery

CineTape

Aerial Filmworks

Tai Audio

Media Blackout - Custom Cables and AKS

Wooden Camera

Rig Wheels Passport

rebotnix Technologies

The Slider