Jump to content


Photo

Leicina Super with Ektachrome 64T


  • Please log in to reply
No replies to this topic

#1 Nick Collingwood

Nick Collingwood
  • Basic Members
  • PipPip
  • 58 posts
  • Other
  • New York, NY

Posted 31 July 2017 - 01:34 PM

So I snagged a Leicina Super (not RT-1, not Special... I wish!) off craigslist a few months ago from an acquaintance who assured me he's shot lots of Tri-X and it's been great. It does sound a bit rough compared to other S8 cameras I have but whatever.

 

Problem is, I perhaps gambled too much and took a roll of Ektachrome 64T and the LS to the beach for a cloudy day and shot it. Just got the roll and 2k scan back and exposure is all over the place. Mostly underexposed but occasionally comes up to normal exposure then back to underexposed. It's very odd. The film stock is fine because I shot a roll in my Canon 814XL-S that came out looking brilliant. Also I did notice that the f-stop was closed down in most shots which surprised me but I had read that the LS should read E64T so I let it do it's thing. Big mistake. Sad to have mostly wasted a precious E64T roll.

 

Any thoughts for why it did that? This is the only roll I've shot with it so maybe it's a bum camera. I believe I had the filter setting on color film-sun (filter engaged) which should be correct.


  • 0


rebotnix Technologies

Tai Audio

FJS International, LLC

Willys Widgets

CineLab

Abel Cine

Gamma Ray Digital Inc

CineTape

Glidecam

Paralinx LLC

Visual Products

Wooden Camera

Aerial Filmworks

The Slider

Metropolis Post

Ritter Battery

Media Blackout - Custom Cables and AKS

Broadcast Solutions Inc

Technodolly

Rig Wheels Passport

Media Blackout - Custom Cables and AKS

Metropolis Post

Visual Products

Gamma Ray Digital Inc

Ritter Battery

The Slider

CineTape

Broadcast Solutions Inc

CineLab

FJS International, LLC

Rig Wheels Passport

Wooden Camera

Aerial Filmworks

Paralinx LLC

Technodolly

Willys Widgets

Abel Cine

Tai Audio

Glidecam

rebotnix Technologies