Jump to content


Photo

Help with Arri 16 BL


  • Please log in to reply
No replies to this topic

#1 Heidi Barker

Heidi Barker

    New

  • Basic Members
  • Pip
  • 5 posts
  • Other
  • Manchester, UK

Posted 11 February 2018 - 03:32 AM

Hi,
I have an arri 16 BL that I picked up reasonably cheaply as it had no working battery. I tracked down a 12v pagbelt but when I plug it in and try to run it, all I get is a red light flash on the back and then nothing.
I don't know if it's worth fixing or just taking off the lens and putting back on eBay as spares/repair. I've also just picked up an arri sr2 which I believe is the better camera.
Does anyone know what could be wrong with the BL? I can film the switch on if it helps? (I can manually turn the gears with the knob by the top of the magazine area (sorry for my ignorance of what everything is called)! So it doesn't appear to have seized)
Any help gratefully received.
Thanks
Heidi
  • 0


Gamma Ray Digital Inc

Visual Products

Abel Cine

FJS International, LLC

Tai Audio

CineLab

Aerial Filmworks

Media Blackout - Custom Cables and AKS

Metropolis Post

Wooden Camera

Ritter Battery

Glidecam

The Slider

rebotnix Technologies

CineTape

Rig Wheels Passport

Broadcast Solutions Inc

Paralinx LLC

Willys Widgets

Technodolly

Ritter Battery

Tai Audio

Technodolly

Media Blackout - Custom Cables and AKS

Glidecam

CineLab

CineTape

Broadcast Solutions Inc

Paralinx LLC

Abel Cine

Willys Widgets

Aerial Filmworks

rebotnix Technologies

FJS International, LLC

Visual Products

Rig Wheels Passport

Metropolis Post

Gamma Ray Digital Inc

The Slider

Wooden Camera